Z1 Designer Software Release Notes Manual Index
Full history of release notes for the Z1 Designer.
v 2022.2
June 27th, 2022
* Added new tool: Gauge tool. This lets you create analogue gauges. There are tons of features on this tool. Stay tuned for the video eplaining them all.

* New Needle Editor. This is where you can create needles that will be used with your gauges. A single needle can be used multiple times in as many different gauges as you like. The Z1 Designer comes with 11 example needles. You can use these in your own designs as is, or you can use them to create your own needles. Or you can create needle designs from scratch.

* The Needle Editor is located under Edit->New Needle.

* To see the list of existing needles look under Edit->Edit Needles.

* You can now rotate the following items: text, conditional text, rectangles, rounded rectangles, and units. To do so you can enter the desired rotation into the Rotation Angle text field in the object properties window. Alternatively you can select the item in the Dashboard window and then drag the handle for the rotation.

* You can now specify an outline for units, text and conditional text objects.

* Added unit specific data channels for Speed, Oil Pressure, Oil Temperature, Water Pressure, Water Temperature and Fuel Pressure. These are intended to be used when creating gauges. But of course you can use them in any object that used data channels. For example there is now 'Speed', 'Speed KPH' and 'Speed MPH'. The 'Speed' data channel will display speed in whatever units the end user has selected. 'Speed KPH' will always display speed in KPH. And 'Speed MPH' will always display speed in MPH.

* There is now a scrollbar that will appear in the Tool Bar window if the window is not big enough to display all tools.

v 2022.1
March 24th, 2022
* The Open Dashboard dialog has been completely reworked. It now is similar to the Dashboard Gallery. It displays a preview of the dashboard along with its name, folder path, and creation date. You can sort the display by name or creation date. To open the dashboard just double click on the desired preview.

* New Tool: LED Group Tool. This tool lets you create multiple LEDs at once. You drag out a rectangle using the tool. This rectangle will then be filled with evenly spaced LEDs. You can choose the number of LEDs, the type of LEDs (circular or rectangular) and their color. When they are arranged as you want them click the 'Create LEDs' button in the LED Group's object properties window. This will create the LEDs assigning them to shift lights, starting with Shift Light 1 and going up to the total number of LEDs you selected. Note you must create the LEDs for them to be saved.

* New Tool: Conditional Text tool. This tool lets you tie the display of text to a data channel. You can then set the text to be displayed based on the values of that data channel.

* Objects can now be 'pinned' to the left edge, right edge or bottom edge of the dashboard window. If an object has one or more of its sides pinned, then as the user adjusts the size of their dashboard window, that edge of the object that is pinned will always stay connected with the edge of the window. If an object can be pinned you will see three 'Pin' checkboxes in the object properties window.

* Objects that are copy/pasted are now pasted into the layer that the original oject was in. So if the original object was in the foreground then the newly pasted object will also be in the foreground. Previously the object was pasted into the currentrly active layer. Thhis could cause problems with objects not being displayed properly if you pasted a foreground object into the background.

* Pasted objects are now not locked regardless of the locked status of the original object. Previously if the copied object was locked then the pasted object would also be locked. But this made it so you could not move the pasted object without first unlocking it.

* There is now an option to show/hide all current guides. This is Edit->Show Guides, or Control-G. Note that objects will still snap to hidden guides.

* The detection for whether or not you clicked within a multi-line shape has been improved. If that shaped is a closed polygon (so the first and last points are the same) then you will have to click inside the object, and not its bounding box to select it. If the shape is an open polygon then clicking within its bounding box will select it.

* The Z1 Designer will now automatically open the dashboard you were working on when you last exited the application. If you do not want the Designer to do this, you can uncheck the Reopen Dashboard option in the General settings tab. With this option unchecked the Z1 Designer will always open to a blank dashboard, as was the case in previous versions.

* Added the following Widgets: Session State; Session Type; Position After Stop; Position/Total Cars; Laps Number of Total Laps.

* Added the following data channels: ERS level percentage; ERS Lap Level Percentage; DRS Uses; Brake Bias Fine; MGUK Deploy Mode; Energy ERS Battery Percentage; Incident Count - Team; Incident Count - Me; Incident Count - Driver; Joker Laps Remaining, Push to Pash Count. Note not all sims support all channels.

* When opening a dashboard if an item is specified as being selected, then its properties will display in the Object Properties window.

* The display names of Conditional Images now include the targeted data channel name.

* You can now specify the background color for the units tool.

* There is now an option in the units tool to display the units in upper or lower case.

* You can now specify a flash speed for any warning. To do so enter the number of milliseconds for each flash in the warning properties window. A value of zero will display the warning consistently without flashing.

* You can preview the warning flashing (animation) by clicking the 'Animate' checkbox in the warning tool's properties window. There is a setting in the General settings tab that determines if newly created objects that have animations will have that checkbox clicked by default or not. Currently only warnings have animations.

* Added car class and class position as options in the Standings tool.

* There is a new option in the standings tool for 'Show Your Class Only'. When this is selected the standings display will only show cars that are in your class in the race.

* There is a new option in the standings tool for 'Display No Change As'. This lets you set what will be displayed in the iRating change and Position change column when there has been no change from the original value. The default is a zero (0).

* When the dashboard needs to be saved an asterisk (*) will appear to the right of the dashboard's name in the Dashboard window.

* There is now an option to turn off the save confirmation message. If you do not want this message to appear after you save your design, uncheck the 'Save Confirmation' option in the General settings tab.

* The Designer will now ask if you'd like to save any changes that have been made when you exit the application if you have not already saved your dashboard design.

* There is a new option in the General settings tab called 'Change Dash Confirmation'. This option is on by default. With this option selected opening or creating a new dashboard when there is an existing dashboard open will result in a prompt asking if you would like to proceed. Note: an unsaved dashboard will always result in a prompt regardless of this option's status.

* There is a new option in the General settings tab called 'Create Preview When Saving'. This option is on by default. When selected a new preview image of your dashboard will be created when you save the dashboard.

* You can now specify the background color of the header row in the standings object.

* Added the following warning options: Engine Stalled, P2P (Push to Pass) Engaged, On Joker Lap

* New options for columns within the Standings tool: Driver Incidents; Team Incidents. Currently only iRacing supports these options.

* You can now choose the style of a track map. They can either be 'normal', which shows the full track map in either static or moving form (as selected by the Dashboard user); or they can be 'flat'. A flat track map is a single straight line going from left to right. This allows for track maps that take up less space than the full track map.

* Added a new widget - Track Map Settings. This will place the track map setting icon, allowing you to display the options for rotating the track map. Note this will not be displayed for flat track maps or moving track maps.

v 2021.4
December 22nd, 2021
* Circle Graph Tool. This is a new tool that lets you create circular graphs. The options are similar to those used in the standard graph tool.

* Competitors Tool. This new tool lets you place information about the drivers directly ahead/behind you on track or ahead/behind you in position. Information currently included is Driver Name, Car Type, Position, Laps Since Last Pit Stop, iRating, Safety Rating, Live Delta, S/F Delta, Last Lap Time, Fast Lap Time, Last Lap Delta, and Fast Lap Delta.

* Arc Tool. This new tool let you create arc segments. They can be open or closed, and filled or empty.

* Added the following widgets: Fuel Buffer, Fuel With Units, Fuel To Finish With Units, Average lap Description, Average Fuel Description, Wind Speed, Wind Direction - Large Arrow, Wind Direction - Small Arrow.

* Added ABS Engaged as a Warning tool option.

* Added Nudge commands. You can move the selected object up, down, left or right by one pixel using them. The keyboard shortcuts are the control key + arrow keys.

* Object locking. You can now lock the location of an object by clicking on the padlock icon in either the layer window or the object properties window. You can also choose to lock all objects by selecting Edit->Lock All Objects, or typing the Ctrl-L keyboard shortcut. All objects can be unlocked by selecting Edit->Unlock All Objects or typing the Ctrl-U keyboard shortcut. When an object is locked it cannot be moved or resized.

* Rulers have been added. You can choose to display these by selecting Edit->Show Rulers. They are displayed by default. The units used in the rulers are pixels. The rulers will show the cursor position as a small line in the ruler. The line is a vertical line on the top ruler, and a horizontal line on the left ruler.

* The current cursor position is now displayed at the top right of the Dashboard window.

* Guides have been added. To use guides you need to have rulers displayed. A guide is a vertical or horizontal line that is used to help align objects in your design. If you move an object near a guide that object will 'snap' to the guide. To create a guide, click on one of the rulers are drag the mouse onto the dashboard design. A new guide will be created and will display on your design. You can move a guide like any other object. Guides are always created in the background. While they are saved with the dashboard design, the are only displayed in the Z1 Designer and not in the Z1 Dashboard.

* When moving guides they will automatically 'snap' to the 1/4, 1/2 and 3/4 distances on the dashboard when moving near those locations.

* Snap Distance - this new drop down is displayed at the top of the Dashboard window. This determines how close an object needs to be to a guide before it 'snaps' to that guide.

* To remove a guide you can delete it by right clicking on its name in the layer window and choosing the delete option. Or you can simply drag it off the dashboard and back onto the ruler.

* Optional tick marks have been added to the graph tool. You can specify their frequency, width and color. For example if you have a graph going from 1000 to 8000, and you specify a tick frequency of 1000, then lines will be draw at 2000, 3000, 4000, 5000, 6000 and 7000 on the graph. Specifying a tick frequency of zero means no ticks will be displayed.

* Text objects can now have a background color.

* Cursor hints have been added for selected objects. The cursor will change when it is over a vertex, or a guide line, to help indicate the way to vertext can be moved.

* When you select an object the coordinates of that object are now displayed next to the object in the design window. This is intended to better feedback on where an object is located. You can specify the font size used for this information in the settings dialog. This feature can also be turned off in the settings dialog.

* Added a vertical scrollbar to the Object Properties window. The scrollbar will appear when necessary when you mouse your mouse over the Object Properties window.

* Rendering updates to improve overall clarity, especially when using Windows scaling other than 100%.

* The settings dialog has been updated to the new format (as used in the Dashboard V2021.3).

* The Designer now remembers the name you enter into the 'Your Name' field in the Gallery Upload dialog. This makes it easier when you are uploading your dashboards as you don't have to re-enter your name every time.

v 2021.3
September 13th, 2021
* The Dashboard Gallery. This is where you can download any currently available dashboards that have been made using the Z1 Designer. These dashboards will have been created by either Z1 Software or other users. To view the gallery select Gallery->View Gallery. You can filter the results by category, sim, or specific search terms. You can scroll up or down using the mouse wheel or the scroll bar on the right egde of the screen. You can collapse or expand a category by clicking on its line within the dashboard gallery. The gallery loads in 20 dashboards at a time. As you scroll down more will be loaded. The preview pictures will be loaded in the first time you open the gallery, and stored on your PC for faster future display. This gallery will grow over time as we, and other users, add more dashboards to it. Any dashboard downloaded from the gallery can be used in the Z1 Dashboard, and can be modified in the Z1 Designer.

* Uploading your dashboards. You can now upload your dashboards to our Dashboard Gallery. The Dashboard Gallery is how dashboards will be distributed moving forward. If you upload your dashboard to the gallery other users will be able to download and use it. To upload your dashboard, go to the Gallery-Upload My Dashboard menu option. This will display a dialog where you can enter your name (very important because we want to credit the dashboard to you!) You can also specify if it is intended for a specific sim, and the category that best described the dashboard. In addition you can enter keywords to help users find it more easily. Clicking the 'Upload' button will start the upload process. Note that when you upload the dashboard it will first be saved, and have a preview image auto-generated to make sure all files are up-to-date.

* A completely new color dialog has been incorporated. This will allow for easier selection of colors, conditional colors and gradients.

* Conditional Images are now supported. A conditional image can have between 2 and 20 images. Each image should have a unique file name. Any current data channel can be used to determine which image is displayed. For each image you specify the minimum and maximum values of the chosen data channel that will trigger that image to be displayed. Conditional images should be placed in the foreground.

* Conditional Colors are now supported. You can create a conditional color by using the Edit->New Conditional Color menu option. This displays the Conditional Color dialog. You assign your color a name, and a data channel that will determine when the color changes. You can have up to 20 color changes within your conditional color. Use the Colors drop down to specify the desired number of colors. To change any of the colors, just click on its swatch and use the color dialog. There are two text fields for each color. They specify the values between which that color will be displayed. Currently all units are in metric values.

* Conditional colors can be permanently or temporary. If you are only going to use the color on one dashboard then it would make sense to create it as a temporary color. It will be saved with the dashboard, but not with the Designer. However if you are going to use the conditional color on multiple dashboards it would make sense to create it as a permanent color. To do this make sure you click the 'Save for future use' check box in the Conditional Color dialog. The permanent/temporary state of any color can be changed at any time you like.

* Conditional colors are saved with their dashboard as needed. So if you open a dashboard that was created by someone else then any conditional colors that are used by that dashboard will be added to your list of conditional colors as temporary colors. This lets you edit the dashboard.

* The names of conditional colors do not have to be unique. This is because if you open a dashboard that someone else created, that dashboard could have a conditional color with the same name as one you have already created. We do, however, recommend using unique names in your own conditional colors for simplicity.

* You can see a list of all available colors, and edit those colors by going to Edit->Edit Conditional Colors. This will display a dialog with the current list of conditional colors. Double clicking on any of them will let you edit the color.

* A conditional color can be assigned to any element created within your dashboard. Simply click the color swatch of the object. This will display the color chooser. At the bottom left is a drop down of the current conditional colors. To assign the color, just choose its name from the list. The color swatch will display the first color in the range along with a 'C' when a conditional color is selected.

* To remove a conditional color from an element, click on the color swatch and in the color dialog choose any other color.

* You can create a new conditional color from within the Color chooser, by selecting '<Add New%gt;' from the conditional colors drop down. This will display the conditional color dialog. If you create a new color it will be added to the drop down in the color chooser and automatically selected.

* Another way to edit an assigned conditional color is to click on the color swatch to open the color chooser. Then within the color chooser if the 'New' color is a conditional color, double clicking on the 'new' color area will display the conditional color dialog allowing you to edit that conditional color.

* You can delete an existing conditional color by going to Edit->Edit Conditional Colors, right clicking on the desired color and choosing 'Delete'. Note if the conditional color is being used by the currently opened dashboard then you cannot delete it.

* You can create a copy of an existing conditional color by going to Edit->Edit Conditional Colors, right clicking on the desired color and choosing 'Copy'.

* Added new warning types: DRS Active, DRS Available, DRS Next Zone, Car Left, Cars Left, Car Right, Cars Right.

* Improvements to the text fields. You can now highlight parts of the text within them using the shift+left/right arrow keys and delete the highlighted text. Double clicking the text field selects all of the text. Left/Right arrow keys now repeat.

* If you place an object in a layer that could make it not display properly you will get a warning dialog asking if you'd like to move it to the correct layer. For example placing a data channel in the background layer would display this warning, as would placing an image in the foreground layer.

* You can now use the TAB key to move to the next text field or drop down.

* The Home/End keys can now be used to move the cursor in a text field.

* The arrow keys can now be used to navigate a drop down's items. The Enter key can now be used to seelct the currently highlighted item in a drop down.

* The copy (CTRL-C) option will now copy any currently selected text in a text field. This copited tex can then be pasted into another text field using the CTRL-V paste option. Note you can have both text and an object in the 'copied' memory. When you go to paste, if a text field is selected then the copied text (if any) will be pasted there, if no text fields are selected then the last copied object (if any) will be pasted on the Dashboard window.

* Select All (CTRL-A) has been implemented. This will select all the text in the currently active text field.

* Added a new widget: Fuel To Add At Stop.

v 2021.2
June 28th, 2021
* When you change the type of a Data Channel, Warning, LED, Widget, Units, or Graph, the Display Name for that object will be updated to reflect the newly type of the object. Note that this will only happen if the Display Name is the default name for that object. If you have manually changed the Display Name, then it will not be changed.

* If an object is selected when the auto-generated preview is requested, the selection bounds of that object are no longer included in the preview image.

* You can now specify the width and height of your dashboard. The default is 480 x 272. This fits most standard USB screens. However if you wanted the larger NASCAR size dashboards of 1280 x 400, then you would just enter those values in to the Dashboard Properties 'width' and 'height' text fields. Any dashboard width and height can be used.

* There is now a 'Track Map' tool. This lets you place a track map object on your dashboard.

* There is now a 'Friction Circle' tool. This lets you place a friction circle on your dashboard.

* There is now an 'Image' tool. This lets you place images on your dashboard. It is recommended that you place images in the background layer. The resolution of the image should be such that it looks good at larger scales. The image must be a PNG image.

* There is now a 'Standings' tool. This lets you place a standings object on your dashboard. The standings object can be customized with the desired number of columns. You can specify what data is displayed in each column, the name of each column and the alignment of the data with each column.

* When creating or resizing objects, holding the shift key down will constrain the object to a square. For ellipses, holding the shift key down while moving the bottom right resize handle will constrain it to a circle. Holding the shift key down while creating a line or multi-line has no effect, as you can accomplish the same by using the Snap To Grid option.

* There is a new 'Toggle Pointer' option under the Edit menu. Selecting this option toggles the currently selected tool with the pointer. After you create an object you can quickly toggle to the pointer to reposition or resize the object, and then toggle back to the tool and create another object. The Space key is the keyboard shortcut for this option.

* In the Text Align drop down in the Object Properties Window the 'Leading' option has been renamed 'Left', and the 'Trailing' option has been renamed 'Right'. This makes it easier to understand the meaning of these options.

* In the Paragraph Align drop down in the Object Properties Window the 'Near' option has been renamed 'Top', and the 'Far' option has been renamed 'Bottom'. This makes it easier to understand the meaning of these options.

* LED objects now have the option to be displayed as either circles or rectangles. This gives you more options for how you want your shift lights and warnings lights to appear on your dashboard.

* Cut, Copy and Paste functions have been implemented. These are available under the Edit menu, or by using the standard Windows keyboard shortcuts (CTRL-C,X,V). Pasting an object will paste the last cut/copied object into the currently selected layer (either Foreground or Background).

* The New Dashboard dialog has been redesigned for better aesthetics, as well as functionality.

* Added two new Widget options: iRating SOF, and iRating Class SOF. iRating SOF shows the average iRating for all entries. iRating Class SOF shows the average iRating broken out by class. These are for iRacing only.

* Added new Widget option: Predictive Lap Time.

* The color chooser now remembers the 16 custom colors for the duration of the Designer being open. You can add a color to the custom color area by clicking on the 'Add to Custom Colors' button. The custom color will be placed into the currently selected custom color slot. Each time you add a new color, the next slot is automatically selected.

* The text fields have been improved. You can now click within the text displayed in the field and edit from that point. You can also use the left/right arrow keys to move around the data within the text field.

v 2021.1.1
April 7th, 2021
* Fixed a bug where a layer would be deleted if you dragged it to the bottom of the list.

* Fixed a bug where layers would sometimes not get transferred between the foreground and background.

* Fixed a bug where the fill color for the multi-line tool did not save.

* Added 'Position' as an option in the Widget tool.

* Added 'Blue Flag', "Full Course Yellow', and 'Local Yellow Flag', as options within the Warning tool.

v 2021.1
March 29th, 2021
* First Release

-- THE BASICS The Z1 Designer lets you create your own dashboards for use with the Z1 Dashboard. A dashboard created in the Z1 Designer requires the same version or higher of the Z1 Dashboard to run. So dashboards created in version 2021.1 of the Z1 Designer will need version 2021.1 or higher of the Z1 Dashboard to run.

Each dashboard currently consists of two files - an XML definition file and a PNG preview image file. Both of these files are placed inside a single folder. This folder should have the same name as the Dashboard. So if you name your dashboard 'My Dashboard', then the folder containing that dashboard's files will be called 'My Dashboard'. The Z1 Designer will create these files and folder automatically when you create a new dashboard.

For a custom dashboard to be available to the Z1 Dashboard its folder should be placed inside the 'Dashboards' folder located inside documents/Z1Dashboard. So with our above example called 'My Dashboard' the folder structure would be 'documents/z1dashboard/dashboards/my dashboard'. The Z1 Designer will place any newly created Dashboards in this location by default.

All custom dashboards available to the Z1 Dashboard will be displayed at the bottom of the Car 2 tab's dashboard drop down.


-- CREATING NEW DASHBOARDS / OPENING DASHBOARDS
After starting the Z1 Designer you need to either Create a new dashboard (File->New Dashboard), or open an previously created dashboard (File->Open Dashboard). There is a sample dashboard provided with version 2021.1 of the Z1 Dashboard. To open this sample dashboard (or any other dashboard) you need to select the 'Dashboard' XML file within its containing folder. To open the sample dashboard select the Dashboard XML file located in 'documents/ z1dashboard/dashboards/Sample Dashboard'.


-- DASHBOARD LAYOUT
All dashboards are separated into two main layers: Background and Foreground. The Background layer is drawn once when the dashboard is created. The Foreground layer is drawn every time the Z1 Dashboard redraws. You should place objects in the appropriate layer when creating your dashboards. Objects that do not change should be placed in the background. Objects that could change (such as data channels, shift lights, warnings, etc) should be placed in the foreground.


-- Z1 DESIGNER WINDOWS
There are 7 windows within the Z1 Designer that you will use to create your dashboard. They are explained below.

You can move any window by dragging its title bar. You can resize any window by dragging its lower right corner. All windows have a minimum size, which they can't be resized below. The Dashboard Properties, Dashboard Defaults and Dashboard Shift Lights windows can be closed by clicking on the X in the top right corner. The other windows cannot be closed. You can display any window by choosing it from the 'Windows' main menu.


-- DASHBOARD WINDOW
This is where your dashboard design is displayed. The dashboard is displayed here exactly as it will appear within the Z1 Dashboard. Resizing this window has the same effect as resizing the Z1 Dashboard. This allows you to see what your Dashboard will look like at different resolutions.


-- TOOL BAR WINDOW
This window displays all available tools. The pointer tool lets you select an object, move it, or resize it. To select an object simply click on it with the pointer. If multiple objects are located in the same place then the one which is 'on top' will be selected. Once an object is selected you can move it by clicking on it and dragging it to the desired location. You can resize a selected object by clicking and dragging on of the displayed resize handles. (To select objects that are underneath other objects, select that object's name in the Layers window.)

The other tools let you add various objects to your dashboard. If you hover the mouse over a tool its function will be displayed. The currently available objects to be added are: Rectangle, Rounded rectangle, Ellipse, Line, Multi-Line, Text, Data channel, Warning, Shift Light, Units, Graph, and Widget. Any newly created object will be placed in the currently active layer. (See the Layer Window section for more information.)

To add any object, select the tool, then click on the Dashboard where you want the object to appear and drag to the right and down to expand the size of the object. It does not matter if you get the size and placement exactly correct as you can move and resize the object at any time. The multi-line tool will add a new line segment every time you use the left mouse button. To end the multi-line object double click the mouse.

'Data Channel' - this displays a specific car data channel, such as gear, RPM, oil temp, etc. Note that data channels associated with user selectable units, like temperatures, will be displayed in the units specified by the user of the Z1 Dashboard when run in the Z1 Dashboard.

'Units' let you display certain units, such as temperature, in the units selected by the user of the Z1 Dashboard. So if you place a units object that is defined to show temperature, it will show 'C' if the user displays temperature in metric units, and 'F' if the user displays them in imperial units.

'Text' - This lets you define a rectangle within which you can display text. Once you create the text rectangle, use the Object Properties window to specify the text to be displayed.

'LED' - This lets you place an LED. There can be up to 15 shift light LEDs and 6 warning LEDs. Each LED can have its own On and Off colors. There is a checkbox within the Shift Lights Properties window that lets you turn the LED on or off to see what it looks like on both configurations. Note this setting has no effect on the Z1 Dashboard, it is only for designing purposes within the Z1 Designer.

'Graph' - This lets you display a data channel as a graph. This is useful for displaying rev counter bars, or brake bias bars, etc. You specify the direction the bar should move in (left to right, right to left, etc). You also specify the data channel associated with it and the minimum and maximum values for that channel.

A 'Warning' object lets you group objects together that are only displayed if the warning criteria is met. For example the pit limiter, or a high oil temperature. A warning object can contain any other type of object except another warning object.

'Widget' - This lets you display various items, or widgets, on your dashboard. Example of these are the lap time, delta time, lap counter, etc.

We suggest playing around with these various tools to see what they do.


-- LAYERS WINDOW
This displays all the objects contained on the background and foreground layers. You can use the scroll bar to move up or down the list if necessary. As mentioned before objects that never change can be placed in the background layer. Objects that could change should be placed in the foreground layer. To set the background as the active layer, click 'Background' in the layers window. To set the foreground as the active layer, click 'Foreground' in the layers window. The currently active layer will be highlighted and have the word 'active' displayed in its header. All new objects are placed on to the currently active layer (either background or foreground).

If you click on the name of an object in the layers window that object will become selected. This allows you to interact with, move and resize objects that are underneath other objects.

The checkboxes on the right side of the layers window allow you to toggle the display of an object on or off. This is intended to make designing your dashboard easier. You may have objects, such as warnings, that you do not need to see all the time when designing your dashboard. Or you may just want to temporarily hide some objects to make it easier to work with other objects. Note the hidden/visible status of an object has no effect on how it is displayed within the Z1 Dashboard.


-- OBJECT PROPERTIES WINDOW
This window displays the properties for the currently selected object in the Dashboard window. The display will change based on what type of object is selected. You can make changes to the currently selected object here as desired.


-- DASHBOARD PROPERTIES WINDOW
This window displays high level dashboard properties. You can change the dashboard's name, background color and preview image here. The preview image is what gets displayed in the Z1 Dashboard in the Car 2 tab when the user is selecting a dashboard.


-- DASHBOARD SHIFT LIGHTS WINDOW
This window displays the options for setting when the shift lights illuminate within your dashboard. If your dashboard does not contain shift lights then you can ignore this window. You can either enter specific RPMs for each shift light illumination, or select an option for them to be automatically turned on at certain RPM values. The drop down on the top right lets you choose this. (Note a user of your dashboard can always override these options. What you are entering here is just the default options for your dashboard's shift lights.)

All gears can use the same RPM shift values, or you can specify unique shift values for each gear. There is a checkbox at the top left that lets you toggle this feature on/off.

Manual Index
(c) zBlueSoftware 2022 | Partners | Forums | Contact Us | Warranty/Terms Of Use | Privacy Policy